2005年下半年 网络工程师 下午试卷

试题一(15分)

阅读以下说明,回答问题(1)~(5),将答案填入答题纸对应的解答栏内。

【说明】

某校园网结构如图C3-1-1所示,采用一个无线网络控制器来自动探测、监控、管理无线 AP。

无线校园网解决方案中采用 Web + DHCP 方式解决用户接入问题,当用户连上无线接入点,由无线网络控制器为用户自动的分配 IP 地址,基于 Web 的认证成功后即可访问 Internet 。认证过程采用 SSL 与 RADIUS 相结合的方式,以防止非法用户的盗用。

【问题1】(4分)

从表C3-1-1中选择合适的设备,将图C3-1-1中(1)~(4)处空缺设备名称填写在答题纸相应位置(每个设备限选一次)。

答案:

(1)AP_2 (2)AP_1 (3)Switch (4)WNC

试题分析:
SSL实际上是共同工作的两层协议组成。SSL安全协议由SSL记录协议、SSL握手协议、SSL告警协议、SSL修改密文协议组成一个协议族。其中SSL记录协议SSL记录协议接收传输的应用报文,经过分片,进行数据压缩,数据加密和装配等过程的处理,然后交给更高级用户,因此它属于应用程和TCP层之间。而SSL修改密文协议SSL修改密文协议是使用SSL记录协议服务的SSL高层协议的3个特定协议之一,也是其中最简单的一个,为了保障SSL传输过程的安全性,双方应该每隔一段时间改变加密规范。
答案:
(5)SSL修改密文协议 (6)SSL记录协议 (7)TCP

【问题3】(3分)

在 SSL 和 RADIUS 相结合的认证方式中,SSL 和 RADIUS 各起什么作用?
答案:
SSL实现信息传输过程中的信息的加密;RADIUS实现对远端拨入用户的身份验证服务。

【问题4】(3分)

如果要对整个校园的无线连接方式进行计费,计费软件应基于 IP 计费还是基于用户帐号计费?简要解释原因。

答案:

基于用户账号进行计费。因为无线部分采用DHCP方式动态分配IP地址,同一地址不同时间分配给不同用户,因此无法基于IP地址进行收费。

试题二(15分)

认真阅读以下说明信息,回答问题1-5。将答案填入答题纸对应的解答栏内。

【说明】

在一个基于 TCP/IP 协议的网络中,每台主机都有一个 IP 地址,根据获得 IP 地址方式的不同,可以分为静态 IP 和动态 IP 。例如:用宽带入网,会有一个固定的 IP 地址,每次连入 Internet ,你的 IP 地址都一样;而用拨号上网,每次连入 Internet 时都能从 ISP 那里获得一个 IP 地址且每次所获得的可能不同,这是因为 DHCP 服务器的存在。在 Linux 中建立 DHCP 服务器的配置文件是 “dhcpd.conf”, 每次启动 DHCP 服务器都要读取该文件。下面是一个 dhcp.conf 文件的实例:
1 default-lease-time 1200;
2 max-lease-time 9200;
3 option subnet-mask 255.255.255.0;
4 option broadcast-address 192.168.1.255;
5 option router 192.168.1.254;
6 option domain-name-serves 192.168.1.1, 192.168.1.2
7 option domain-name “abc.com”
8 subnet 192.168.1.0 netmask 255.255.255.0
9 {
10 range 192.168.1.20 192 .168.1.200;
11 }
12 host fixed{
13 option host-name “ fixed.abc.com”;
14 hardware Ethernet 00:A0:78:8E:9E:AA;
15 fixed-address 192.168.1.22;
16 }

试题解析:
192.168.1.20~192 .168.1.200这个范围有181个地址,所以标准答案是181。但由于后面有设置将192.168.1.22这个地址与00:A0:78:8E:9E:AA进行绑定,所以回答180也可以算对。
答案:
标准答案181个,宽松答案180个。

【问题2】(3分)

该 DHCP 服务器指定的默认网关、域名及指定的 DNS 服务器分别是什么?
答案:
该DHCP服务器指定的默认网关:192.168.1.254 域名是:abc.com
指定的 DNS 服务器是:192.168.1.1和192.168.1.2

【问题3】(3分)

该配置文件的12-15行实现什么配置功能?、

图C3-2-1

答案:

为网卡的MAC地址是“00:A0:78:8E:9E:AA”的客户端主机分配固定IP地址:192.168.1.22。为该客户分配主机域名:“fixed.abc.com”。

【问题4】(3分)

在 Windows 操作系统中,DHCP客户端 “Internet 协议(TCP/IP)属性”配置界面如图C3-2-1所示。在此界面中,客户端应如何配置?

答案:

在此界面中客户端点选“自动获得IP地址”选项。

试题三(15分)

阅读以下说明,回答问题1到问题5。将答案填入答题纸对应的解答栏内。

【说明】

某企业采用 Windows2000 操作系统部署企业虚拟专用网(VPN),将企业的两个异地网络通过公共 Internet 安全的互联起来。微软 Windows2000 操作系统当中对 IPSec 具备完善的支持,下图给出了基于 Windows2000 系统部署 IPSec VPN 的网络结构图。

【问题1】(2分)

IPSec 是 IETE 以 RFC 形式公布的一组安全协议集,它包括 AH 与 ESP 两个安全机制,其中 (1) 不支持保密服务。

答案:

(1)AH

【问题2】(4分)

IPSec 的密钥管理包括密钥的确定和分发。IpSec 支持 (2) 和 (3) 两种密钥管理方式。试比较这两种方式的优缺点。

答案:

(2)自动密钥分配
(3)手动密钥分配 手动密钥分配的优点是简单,缺点是安全性低

【问题3】(4分)

如果按照图中所示网络结构配置 IPSecVPN ,安全机制选择的是 ESP ,那么 IPSec 工作在隧道模式。一般情况下,在图中所标注的四个网络接口中,将 (4) 和 (5) 配置为公网 IP ,将 (6) 和 (7) 配置为内网 IP 。

答案:

(4)NIC2或NIC3 (5)NIC3或NIC2,但是和(4)不能相同
(6)NIC1或NIC4 (7)NIC4或NIC1,但是和(6)不能相同

【问题4】(3分)

在 Internet 上捕获并分析两个内部网络经由 Internet 通信的 IP 包,在下列三个选项中选择正确选项填写到图3-2中相应空缺处。
(a)ESP 头 (b)封装后的IP包头 (c)封装前的IP头

答案:

(8)b (9)a (10)c

试题四(15分)

请认真阅读下列关于计算机网络防火墙的说明信息,回答问题1-5。将答案填入答题纸对应的解答栏内。

【说明】

某单位的内部局域网通过防火墙与外部网络的连接方式及相关的网络参数如图 C3-4-1所示。

【问题1】(4分)

完成下列命令行,对网络接口进行地址初始化的配置:
firewall (config)#ip address inside (1) (2)
firewall (config)#ip address outside (3) (4)

答案:

(1)192.168.0.1 (2)255.255.255.0
(3)202.117.12.37 (4)255.255.255.252

【问题2】(4分)

与路由器一样,防火墙的网络地址转换功能可以实现内部网络共享出口 IP 地址。根据网络连接示意图4-1提供的网络参数,完成下列命令行的配置内容,以实现整个内部网络段的多个用户共享一个 IP 地址。
firewall(config)# global(outside) (5) netmask (6)
firewall(config) # nat(outside) (7) (8)

答案:

(5)202.117.12.37 (6)255.255.255.252
(7)192.168.0.0 (8)255.255.255.0

【问题3】(2分)

如果允许内部任意 IP 地址都可以转换出去,则:
firewall (config)# nat (outside)(9)(10)

答案:

(9)0.0.0.0 (10)0.0.0.0

【问题4】(2分)

访问控制列表是防火墙实现安全管理的重要手段。完成下列访问控制列表(access-control-list)的配置内容,使内部所有主机不能访问外部 IP 地址段为202.117.12.0/24 的Web服务器。
Firewall(config)#access-list 100 deny tcp (11) 202.197.12.0 255.255.255.0 eq (12)

答案:

(11)any(all也给分)(12)www(或80)

试题解析:
CISCO公司IOS系统ACL命令的格式是这样的:
access-list acl_id {deny|permit} protocol source [source-wildcard] destination [destination-wildcard] [operator port] [established]
问题4的例子是这样写的:
内部所有主机不能访问外部 IP 地址段为202.117.12.0/24 的Web服务器
access-list 100 deny tcp any 202.197.12.0 255.255.255.0 eq www
从这个命令看,它符合source在前,destination的特点,但是没有使用通配符掩码wildcard。如果使用通配符掩码,则应该是
access-list 100 deny tcp any 202.197.12.0 0.0.0.255 eq www
所以,问题4的例子使用的不是CISCO的命令格式,可能是其他厂商的格式。
其格式有两种可能:
一:access-list acl_id {deny|permit} protocol source [subnet-mask] destination [subnet-mask] [operator port]
二:access-list acl_id {deny|permit} protocol inside [subnet-mask] outside [subnet-mask] [operator port]

问题5的要求是使外部所有主机不能访问内部 IP 地址为 192.168.0.10的FTP服务器,并仿照上一个访问控制列表的命令行格式,给出访问控制表的命令行。
如果按照第一种格式,答案应该是
access-list 101 deny tcp any 192.168.0.10 255.255.255.0 eq 21(或ftp)
如果按照第二种格式,答案应该是
access-list 101 deny tcp any 192.168.0.10 0.0.0.255 any eq 21(或ftp)
标准答案是access-list 101 deny tcp 192.168.0.10 255.255.255.0 any eq 21(或ftp)
因此判断该设备使用的是第二种格式。

应该说这个小题确实容易误导,而且该厂商的设备可能也非主流。所幸后来历届考题都没有再这样出题。
答案:
firewall(config)#access-list 101 deny tcp 192.168.0.10 255.255.255.0 any eq 21(或ftp

试题解析:
CISCO公司IOS系统ACL命令的格式是这样的:
access-list acl_id {deny|permit} protocol source [source-wildcard] destination [destination-wildcard] [operator port] [established]
问题4的例子是这样写的:
内部所有主机不能访问外部 IP 地址段为202.117.12.0/24 的Web服务器
access-list 100 deny tcp any 202.197.12.0 255.255.255.0 eq www
从这个命令看,它符合source在前,destination的特点,但是没有使用通配符掩码wildcard。如果使用通配符掩码,则应该是
access-list 100 deny tcp any 202.197.12.0 0.0.0.255 eq www
所以,问题4的例子使用的不是CISCO的命令格式,可能是其他厂商的格式。
其格式有两种可能:
一:access-list acl_id {deny|permit} protocol source [subnet-mask] destination [subnet-mask] [operator port]
二:access-list acl_id {deny|permit} protocol inside [subnet-mask] outside [subnet-mask] [operator port]

问题5的要求是使外部所有主机不能访问内部 IP 地址为 192.168.0.10的FTP服务器,并仿照上一个访问控制列表的命令行格式,给出访问控制表的命令行。
如果按照第一种格式,答案应该是
access-list 101 deny tcp any 192.168.0.10 255.255.255.0 eq 21(或ftp)
如果按照第二种格式,答案应该是
access-list 101 deny tcp any 192.168.0.10 0.0.0.255 any eq 21(或ftp)
标准答案是access-list 101 deny tcp 192.168.0.10 255.255.255.0 any eq 21(或ftp)
因此判断该设备使用的是第二种格式。

应该说这个小题确实容易误导,而且该厂商的设备可能也非主流。所幸后来历届考题都没有再这样出题。
答案:
firewall(config)#access-list 101 deny tcp 192.168.0.10 255.255.255.0 any eq 21(或ftp

试题五(15分)

阅读以下说明,回答问题1~5,将答案填入答题纸对应的解答栏内。

【说明】

利用 VLAN 技术可以把物理上连接的网络从逻辑上划分为多个虚拟子网,可以对各个子网实施不同的管理策略。图C3-5-1表示两个交换机相连,把 6 台计算机配置成连个 VLAN 。

【问题1】(2分)

双绞线可以制作成直连线和交叉线两种形式,在图5-1中,两个交换机的 UPLINK口相连,使用的双绞线制作成什么形式?连接交换机和计算机的双绞线制作成什么形式?

答案:

两个交换机的UPLINK口相连,使用的双绞线制作成交叉线。
连接交换机和计算机的双绞线制作成直连线。

【问题2】(7分)

阅读一下的配置信息,将(1)~(4)处空缺的内容填写在答题纸相应位置。
SW1>enable (进入特权模式)
SW1#vlan database (设置 VLAN 配置子模式)
SW1(vlan)#vtp server (设置本交换机为 Server 模式)
SW1(vlan)#vtp domain (1) (设置域名)
SW1(vlan)# (2) (启动修剪功能)
SW1(vlan) exit (退出 VLAN 配置模式)
SW1#show (3) (查看 VTP 设置信息)
VTP version : 2
Configuration Revision : 0
Maximum VLANs supported locally :64
Number of existing VLANs :1
VTP Operating Mode :Server
VTP Domain Name :Server1
VTP Pruning Mode :Enable
VTP V2 Mode :Disabled
VTP Traps Generation :Disabled
MD5 digest :0x82 0x6B 0xFB 0x94 0x41 0xEF 0x92 0x30
Configuration last modified by 0.0.0.0 at 7-1-05 00:07:51

SW2 #vlan database
SW2(vlan) #vtp domain NULL
SW2(vlan) # (4)
Setting device to VTP CLIENT mode
SW2 (vlan) # exit

答案:

(1)Server1(2分) (2)vtp pruning(1分)
(3)vtp status(2分) (4)vtp client(2分)

【问题3】(2分)

阅读以下的配置信息,解释(5)处的命令,将答案填写在答题纸上相应的位置。
Switch#
Switch#config
Switch(config) #interface f0/1 (进入接口1配置模式)
Switch(config-if)#switchport mode trunk (5)
Switch(config-if)#switchport trunk allowed vlan all (设置允许从该接口交换数据的vlan)
Switch(config-if)#exit
Switch(config)#exit
Switch#

答案:

(5)设置当前端口为Trunk模式

【问题4】(2分)

阅读以下的配置信息,解释(6)处的命令,将答案填写在答题纸上相应的位置。
Switch #vlan d
Switch(vlan)#vlan 2 (创建一个VLAN2)
VLAN 2 added
Name:VLAN0002 (系统自动命名)
Switch(vlan)#vlan 3 name vlan3 (6)
VLAN3 added:
Name:vlan3
Switch(vlan) #exit

答案:

(6)创建一个VLAN3,并命名为vlan3